Opened 6 years ago

Closed 6 years ago

#4 closed defect (fixed)

HTC Evo 3D issue with Android release 1.0

Reported by: sc Owned by:
Priority: normal Milestone:
Component: Android Version: 1.0
Keywords: Cc:

Description (last modified by sc)

User reports:

My Puzzlebox Orbit arrived today, with the headset and dongle. I followed all of the instructions. I've come to the conclusion that there is an issue with the signal getting from my HTC Evo 3D phone to my orbit helicopter.

Please note: When I connect it with my husband's Samsung Transform Ultra, it works. Everything is the same in what I did to work with his phone as when I set it up with mine. The volume control is "Media Volume" and it's at high with his, as it is with mine.

Here's what I did:

  • I have made sure that it's fully charged and the dongle is fully charged.
  • The headset has a battery, is on, and successfully pairs with the bluetooth on my HTC Evo 3D.
  • All of the available volume controls (Media volume and ringer volume) are turned to the maximum. I don't believe there is any other way to adjust a volume. I checked the manual to make sure.
  • The helicopter is powered on and the blue light is flashing.
  • The Orbit app is installed, and gets a fully green signal line, and the blue and red attention and meditation lines are moving in response to the signals from the headset via the bluetooth.
  • I also tested the headset with other neurosky apps on my HTC, and the headset works with those.
  • I turned everything on and off and rebooted my phone.
  • I clicked Test Helicopter. The blue light on the dongle flashes. The helicopter doesn't move. The blue light in the helicopter continues to flash.
  • Through each time I tested this, and I tried for about an hour and a half, the helicopter never responded in any way other than to flash the blue light when connected to my phone.

Based on these tests, it seems that the helicopter doesn't work with my phone. Is there a patch or something that can be used from my phone?

Please advise me.

Thank you and happy holidays.

Change History (9)

comment:1 Changed 6 years ago by sc

  • Description modified (diff)

comment:2 Changed 6 years ago by sc

Response to user:

Many thanks for the detailed bug report!

It seems that certain phones require a slightly different control signal to be generated by our software in order for the audio hardware to match the correct timing expected by the IR dongle.

We are working on an update right now which should address this as well as add the ability to set throttle level (to fine-tune the hover settings) as well as support spin control and forward motion.

In the short term, it would be useful if you could please test a release we produced specifically for the HTC One X phone:

http://orbit.puzzlebox.info/files/puzzlebox_orbit-htc_one_x.apk

In addition, this issue is now being tracked through our online system:

http://orbit.puzzlebox.info/tracker/ticket/4

You can register for an account to update the ticket here:

http://orbit.puzzlebox.info/tracker/register

We will be happy to keep you updated directly as well.

comment:3 Changed 6 years ago by alangholt

Thank you. I will advise when I've tested the new version in a short while.

In addition, when used with my husband's phone, it does fly out of control about the room rather than go up and down.
I'm glad you are working on this.

comment:4 Changed 6 years ago by alangholt

Sorry. Same issue with the test version. No change.

I await your response and thanks for your work on this.

comment:5 Changed 6 years ago by sc

Thanks for the quick response!

Please give Developer Preview Release 1.1.1 for Android a try.

You may need to enabled the "Invert Control Signal" setting.

comment:6 follow-up: Changed 6 years ago by alangholt

Hi there,

I just downloaded the Dev Preview Release 1.1.1 for Android, and installed. Interestingly enough, I did get a response from the orbit, but it wasn't enough to fly. In fact, the propellers moved slow and jerky and the blue light became very dim. I tried every channel (I think C seemed to be best, with Invert Signal enabled as you said). I tried with the torque all the way up, but it didn't seem to make any difference.

I decided to put it on the charger, though I'm not really clear if the power switch should be off or on when charging. When it's on, the light on the plug is brightly shining. (Making me think it's fully charged). But the same problem persists when I try to run it again.

Can you confirm the correct way to charge the orbit and how to tell when it's out of charge?

I'll also try the new version with my husband's Samsung. It ran with that, but it was slow to respond and it rolled all over the room instead of hovering (which I hope the new pitch controls will help adjust).

Also if it would help, I could submit a video.
Thanks.

comment:7 in reply to: ↑ 6 Changed 6 years ago by alangholt

I just installed the dev version on my husband's Samsung, but the full screen wouldn't appear in the viewing window, so there was no "invert signal" or "test helicopter" option showing.

comment:8 Changed 6 years ago by alangholt

Okay more news!

I charged the orbit with the power off (not sure if that is the right way or not as the plug remained white). Then I tried it again with my HTC Evo 3D. It DID launch this time, although with the throttle all the way up, it didn't get higher than about 3 inches at a time. It also did try to fly around the room. I'm working on adjusting the pitch control and the yaw (not sure exactly what yaw is yet) to try to get it to stay in one general area and just go up and down. It's an improvement.

I really need more throttle power. Even with the highest setting, I'm not getting much liftoff. But maybe this is more of a charging issue.

I put it back on the charger and am letting it have a good while to charge, in case that will be what makes the difference.

Thanks.

comment:9 Changed 6 years ago by alangholt

  • Resolution set to fixed
  • Status changed from new to closed

Okay there's more news!

I had the orbit on the charger cable with the orbit switched to off. After about an hour, the plug glowed red! So aha! The orbit was fully charged. I set it up again with my EVO, and it shot up to the ceiling.

It's working now. I'm still working on adjusting the pitch and yaw to keep it stable, but I think the answer was that the orbit has to be fully charged.

My EVO needs channel C and Inverse signal. The throttle now doesn't need to be at full (or it hits the ceiling).

So I think this is all a learning experience and this ticket can probably be closed and marked as resolved.

Thank you so much. I'm glad I had the day to play with the possibilities.

Alice

Note: See TracTickets for help on using tickets.