Opened 6 years ago

Closed 6 years ago

#19 closed defect (fixed)

Puzzlebox Orbit Not Charging

Reported by: sc Owned by:
Priority: normal Milestone:
Component: Android Version: 1.2
Keywords: Cc:

Description

An email was received from a customer:

Hey Team Puzzlebox,

I received my Orbit Helicopter about a week ago and I'm sorry to say that it has not been functioning since the day I received it.

Something is wrong with the charging unit of the Helicopter. I am unable to charge it. I am able to plug the charger into the unit but, alas nothing charges. I have attached a photo of an attempt to charge the helicopter. Is that light supposed to turn on when it's charging?

Looking forward to your assistance

Attachments (1)

IMG_0918.JPG (197.3 KB) - added by sc 6 years ago.
Attempt to charge the helicopter

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by sc

Attempt to charge the helicopter

comment:1 Changed 6 years ago by sc

Response to user:

Hi Xxxxxxx, thanks for writing.

It is possible either the battery in your Orbit or the USB charging is defective, in which case we can exchange them for a new set.

This can first be tested however:

The USB charging cable is also used to charge the infrared transmitter. When you first plug the USB cable into the USB port, if there's nothing attached on the other end, you should see a red charging light inside the base of the cable. As soon as you plug the charging end in the transmitter or Orbit, the light should go out.

Next, you should see a red charging light on the transmitter when it is charging. Once charged you can connect the transmitter to your mobile device, raise the volume to maximum, and use the "Test" options to trigger a test flight. This should cause the blue light on the transmitter to turn on.

If all of the above works, then the problem is not the USB charging cable.

Finally, once the USB charging cable is confirmed, please check that the OFF/ON switch on the Orbit is in the "OFF" position before plugging in the cable. It is very small and easy to miss, and if the Orbit is switched to "ON" when attempting to charge it will not charge up.

Please let us know how things go and if necessary we will arrange for an exchange.

comment:2 Changed 6 years ago by sc

Response to user:

Oh, and I almost forgot to mention -- no, the LED on the Orbit does not light up while charging.

It blinks blue when the Orbit is powered on (and has a charge).

comment:3 Changed 6 years ago by sc

Response from user:

I am really pleased to say that everything is working properly. The issue was just recognizing that the USB charger was in fact charging the helicopter. The useful nugget of information that you shared was the fact that the USB charger will not show the red light when placed in properly. This was a subtlety that clearly went over my head.

On a side-note, it did require me to wiggle & push the charger around a bit to ensure that it was placed properly in the helicopter. Using the red light on the other end of the charger was very useful in verifying the charge was happening.

Additionally, I would not mind at all if this email was posted in the FAQ / Ticket system. I hope my issue helps others and saves the team time!

Thank you very much for the help Steve,

Cheers!

comment:4 Changed 6 years ago by sc

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.